Tick Talk on EsoxRepublic.com


Esox “Copy Custom Info” revived and updated guts

Posted in API, Esox Software, Software by Administrator on the May 1st, 2010

You just never know how popular some things are until they break.  This apparently is true for my “Copy Custom Info” macro.  The macro seems to have stopped working for many SW 2010 users.

The macro is ancient, by API standards.  It is one of my first published macros, and was written in SW2003.  Judging by the code, I wrote it before I was aware of early binding.  Also, SW’s API has come a long way and there were many ways to streamline the code.

I was able to do away with much embarrassing sophomoric hacksmanship. Glad to get that behind me.  Most notable improvement is that the program no longer needs to make duplicates of the files it is copying from (do not judge, I had my reasons!).  Assemblies and drawings selected for copying will open much faster.

The interface is about the same.  The only visible improvement will be in the preview windows.  There will be some indication that this is the SW2009 version.

The program will be posted on EsoxRepublic.com in the coming week.  Notices to be placed in popular forums that your less-popular author frequents.

One Response to 'Esox “Copy Custom Info” revived and updated guts'

Subscribe to comments with RSS

  1. JeffCox said,

    on February 5th, 2013 at 6:46 pm

    Your macro works as advertised. Really appreciated. But when I try to assign a button to it…it doesn’t work. Any ideas?

    Thanks for offering this
    J

Leave a Reply

You must be logged in to post a comment.